
ORNL is managed by UT-Battelle, LLC for the US Department of Energy

Advanced User Interface Capabilities

Robert A. Lefebvre

SCALE Users’ Group 2020

Reactor and Nuclear Systems Division

Oak Ridge National Laboratory, USA



2

Summary
This tutorial will review the data plotting and geometry 
visualization capabilities in the Fulcrum user interface. This tutorial 
will help you become familiar with Fulcrum’s 2D plot, and 2D and 
3D geometry visualization features. 

You will learn how to identify plottable data items, compose and 
export plot and plot data for SCALE plot formats (SDF, Ampx 
MG/CE, PLT, F71, PTP, SPF, ORIGEN Gamma data, etc.) and 
visualize, navigate, cut, hide, and export the geometry and 
spatial data (fission-, dose-map, etc.) overlays in 2D and 3D.

No prior experience with SCALE is required. Attendees can follow 
along using 6.3.0-beta.
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User Notice

This tutorial is intended to train users in the advanced 
functionality of the Fulcrum data and geometry plotting 
capabilities. 

It is not intended to train users in the use of the SCALE code 
system’s cross section processing, criticality safety, depletion, 
shielding, sensitivity and uncertainty, or source term 
computational modules.

Schedules and contact information for specific tutorials and 
training courses can be found 
at https://www.ornl.gov/scale/scale-training

https://www.ornl.gov/scale/scale-training
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Outline
• Vision
• Fulcrum Component 

Overview
• Plotting Overview
• Plot Controls
• 2D Plots

– AMPX Cross Section Data (MG, 
CE) plots

– Covariance data plots
– ORIGEN Gamma data
– Sensitivity Data File (SDF) plots
– ORIGEN F71 Plot

– OPUS PLT
– MAVRIC ChartPlot plots
– Scale Plot Format (SPF) plots
– KENO PTP Results plots

• Plot saving
– PDF, PNG, SPF

• Geometry Visualization
– Activation and Layout
– 2D Controls
– 3D Controls
– Spatial data plotting
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Fulcrum Mission Statement

Provide a cross-platform graphical user interface (GUI) 
designed to facilitate problem creation, modification, 
navigation, validation, and visualization, as well as output and 
data file interaction as needed by new and experienced users.
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Fulcrum Components Overview 
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Fulcrum Components Discussed Geometry 
Visualization and 

data overlay 

Data Plotting
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Tutorial Requirements

• Have SCALE 6.3 beta installed 
• SCALE Data installed
• Have Advanced_User_Interface training pack downloaded

– includes input and data files 
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Fulcrum Startup Screen

• Start Fulcrum
• Little to look at
• Lean and mean
• Always has a terminal/CMD 

window in the background
that contains log messages
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Data Plotting
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Data Plotting Overview

•Plot Controls
•AMPX Cross Section Data
•Covariance Data
•ORIGEN Gamma Data
•ORIGEN Isotope Concentration Data (F71)
•F71 Special Plot Controls (PlotOpus)
•Sensitivity Data Files (SDF)
•Result Plots (KENO PTP, MAVRIC ChartPlot, Opus PLT, etc.)
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General Plot Overview
• Interactive and configurable plot rendering
• Plot data table displays graph data.

– Allows column, row and table copy-to-clipboard.



1313

Plot Controls
Fulcrum plots consist of graph, bars, or color maps, 
which can be manipulated as follows.
• Select graph via left click in plot or legend

– Remove selection via context menu ‘Remove selected’

• Zooming is performed via the mouse/trackpad scroll action
– Zoom in by scrolling up
– Zoom out by scrolling down

• Panning is performed via a left-click and drag
– Pan right by left-click and dragging left
– Pan up by left clicking and dragging down

• Plot Legend can be dragged to 9 positions via left-click and 
drag

• Plot attributes (color, style, etc.) can be changed via context 
menu Plot options

• Reset to original extents via context menu Fit graphs

• Save Plot as 
PDF (includes scalable vector graphics 
SVG)
PNG and JPG image format
Interactive Scale Plot Format (SPF)
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Plot Controls | Hands On
• Click File > Open file… and  open 

Advanced_User_Interface/ChartPlot/
binned.chart

• Observe the binned.chart file become 
visible in the Navigation panel and a 
new binned.chart text editor tab

• Note the Navigation panel’s 
Plottable icon

• Double left-click the binned.chart > 
document plottable item to plot the 
entire document
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Plot Controls | Hands On Graph Selection

• Select the green Sampled PDF graph 
via a left-click on the green line

• Observe the selected graph turn blue, the 
Legend graph entry text color become 
blue with line style emphasized via a blue 
box, and the cursor location include the 
graph name Sampled PDF

• Alternatively, a graph selection can be 
made in the Legend via a left-click of the 
graph name

• Deselection is accomplished by a left-click 
in an empty plot location
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Plot Controls | Hands On Zooming and Panning

• Zoom in to the graph peak via scrolling 
up

• Pan down via left-click and drag down



1717

Plot Controls | Hands On Legend Position

• The Legend can be positioned in 9 
locations the default is upper-right corner

• Left-click and drag the Legend to the 
upper-left corner

• Observe the Legend snap from the 
upper-right corner to the upper-center to 
the upper-left corner
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Plot Controls | Hands On Plot Options

• Right-click on the Plot and select Plot 
options

• Chart allows changing the plot title’s
– text, 
– font, 
– color, and 
– visibility
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• In the Title Value column remove the existing title and enter ChartPlot Tutorial
• Observe the 

Plot Tab title and 
Plot Title update

Plot Controls : Plot Options Chart Changes  
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Plot Controls : Plot Options Legend  

• Legend allows changing the legend’s font and visibility
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• Click the Font editor ellipsis …
– Note the ellipsis button will appear when the 

Value column field is selected
– Platform-specific (Windows, Mac, Linux) Font 

chooser may appear different than illustrated

• Change the Typeface to be Bold
• Click OK to close the Font editor

• Observe the Legend items become Bold

Plot Controls : Plot Options Legend Changes 
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Plot Controls : Plot Options Axes  

• Axes allows changing axis
– visibility, 
– label text, 
– text font and color, 
– Scale (linear or log), 
– range, 
– grid, 
– tick label font and attributes 

(rotation, precision, etc.)
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Plot Controls : Plot Options Graphs  

• Graphs allows changing 
– graph name, 
– line style, color, and weight, 
– scatter style, and size, 
– pen style,
– adaptive sampling*, 
– errors bars.

* adaptive sampling – conducts intelligent sampling of the data points providing significant 
speed up when many data points are involved. Default is on.
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• Change the True PDF Scatter Style to PlusSquare
• Observe the True PDF Legend entry style update
• Click OK to close the Options dialog

Plot Controls : Plot Options Graph Changes  
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• Select the Sampled PDF 
graph via left-click the 
graph in the plot or in the 
Legend

• Right-Click anywhere in 
the plot and select 
Remove selected 

• Observe the Sampled 
PDF is removed from the 
plot and Legend

Plot Controls : Graph Removal
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• In the Navigation panel 
right-click the Sampled PDF

• select Add graph to 
“ChartPlot Tutorial”

• Observe the Sampled PDF
is added to the Plot and 
Legend

• Plot graphs can be added to 
any plot that has matching 
axis names

Plot Controls : Graph Addition
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Plot Controls : Plot Options Graph Pen Style

• Right-click the plot and select 
Plot Options

• Update the Sampled PDF Pen 
Style to be Dashed

• Click OK
• Observe the update in the plot 

legend and plot, and the 
improved visibility of True PDF
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• Save as PDF uses Scalar Vector 
Graphics (SVG) to improve 
incorporation into reports

• Right-click the plot and select 
Save as… > PDF

• Save as ChartPlotTutorial.pdf

• Open in your PDF viewer and 
observe report-ready figure

Plot Controls : Save As PDF
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• Save as SPF preserves range and all data 
(outside zoom) for collaboration

• Right-click the plot and select Save as… > SPF
• Save as ChartPlotTutorial.spf
• Open the SPF file via File > Open file… and 

select ChartPlotTutorial.spf
• Observe the ChartPlotTutorial.spf

available in the Navigation panel
• Double left-click the 

ChartPlotTutorial.spf > document
plottable item

• Observe the new plot 

Plot Controls : Save As SPF
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• Right-click on the plot and select Fit graphs to zoom out to the extents of the 
graph data

• Useful for quickly identifying the data extents and features

Plot Controls : Fit graphs
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Plot Controls : Plot Options Mentionables

• When the plot is of bars the Bars menu allows changing bar graph name
• When the plot is a color/heat map the Color Map menu allows changing color 

map graph name and color gradient
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Plot Table

• To see graph data select the Table plot tab
• Row, Column, and Table selections allow easy 

copy-and-paste into Excel, etc.
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Plotting | Review
• You are now practiced in 

– Graph selection, removal, and addition
– Graph zooming via mouse/trackpad scrolling
– Graph panning via left-click and dragging
– Graph Legend position adjustment via left-click and dragging 
– Graph data table acquisition
– Plot attributes (color, style, etc.) via context menu Plot options
– Reset to original extents via context menu Fit graphs

• Questions?
• Close all open documents via File > Close All
• Close all tabs via right-clicking any tab and selecting Close all tabs
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AMPX Cross Section Data
AMPX Cross Section Data is available in multigroup (MG) and 
continuous-energy form and is located at ${SCALE}/data. Because the 
files do not have a unique extension, the user must load them 
specifically by type. 

• Load MG XS data via File>Open multigroup library…

• Load CE XS data via File>Open continuous-energy library...

• CE XS data are displayed hierarchically 
– by Neutron or Photon, Isotope, Temperature (K), and Reaction.

• MG XS data are displayed hierarchically 
– By Isotope, Neutron or Gamma, Reaction XS 

or transfer array. 
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AMPX XS| Hands On
• Click File > Open multigroup 

library… and  open 
Advanced_User_Interface/AmpxMG/
example-8grp.mg

• Observe the example-8grp.mg file 
become visible in the Navigation 
panel

• Double left-click each (h-3, he-4) to 
load individual data sets into Fulcrum
– Because MG libraries can be large Fulcrum 

in 6.3 (beta 12+) no longer loads all data
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AMPX XS |MG Hands On

• Plot h-3 mt=1 total and 
the he-3 mt=1 total on 
separate plots

• Split the Fulcrum 
workspace by dragging 
the he-4 mt=1 total tab 
and dropping it at the 
bottom-center (on top 
of ‘Energy (ev)’ axis 
label) of the plot

• Change the Legend
position to not overlap 
the data
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AMPX XS| Hands On
• Click File > Open continuous-energy library… 

and  open Advanced_User_Interface/AmpxCE/
example.ce.xml

• Observe the example-ce.xml file become visible 
in the Navigation panel

• Expand the Neutron and subsequent h-3 and 
he-3 Navigation item and observe their available 
temperatures

• Double left-click each 293 (h-3, he-4) to load 
individual temperature data sets into Fulcrum
– Because CE libraries are large Fulcrum doesn’t load all 

temperature data automatically

• Observe the nuclide reaction listed in the 
Navigation panel
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AMPX XS| Hands On

• Expand the h-3 mt=1 total and 
add the h-3 mt=1 total 293 k xs
to the existing h-3 mt=1 total
multigroup plot

• Expand the he-4 mt=1 total and 
add the he-4 mt=1 total 293 k 
xs to the existing he-4 mt=1 
total multigroup plot

• Observe the comparison of the 
MG and CE cross sections

• Questions?
• Close all files and tabs
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ORIGEN Gamma Data
The master photon data library, located at SCALE/data/origen_data/origen.rev##.mpdkxgam.data, 
provides both discrete and continuous energy gamma lines.

• Opened via File>Open ORIGEN gamma data…
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Covariance Data
Covariance Data is available in SCALE/data. Because the files do not 
have a unique extension, the user must load them specifically using 
File > Open covariance library…. 

• Correlation coefficient matrix color map plots

• Covariance matrix color map plots

• Isotope Reaction Standard Deviation by energy or group graph plots
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Covariance| Hands On
• Use File > Open Covariance 

Library… to open the SCALE/data/
scale.rev??.252groupcov7.1

• Observe the 252groupcov7.1 
display in the Navigation panel

• In the Navigation panel’s Filter 
field enter u-235.mt=18
– Note the period (.) indicates a match of 

anything and finds item labels with 
either a space or hyphen

• Observe all matches presented
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Covariance| Hands On Std Dev

• Plot the u-235 mt=18 fission – Std dev by energy
• Observe the ~78% std-dev @ ~2.2 keV
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Covariance| Hands On Correlation Coefficient Matrix

• Plot the u-235-mt=18 fission to 
u-235-mt=18 fission –
Correlation coefficient matrix

• Close all files and tabs

• Remove the Filter u-235.mt=18 
fission
– If you forget subsequent file content may 

not be displayed because it doesn’t match 
the filter 
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ORIGEN Isotope Concentration Data (F71)

Origen concentration data contains results from depletion, decay, and activation 
calculations. The plot capabilities are centered about the expected Fulcrum 
interactive plot controls with the addition of a more familiar PlotOPUS -style set of 
controls.
• Easy selection 

of state information 
to display.

• Easy display 
of nuclides or 
elements by id 
or category.

• Easy display of 
different units 
(Decay, Mass, 
Number).
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ORIGEN F71 Special Plot Controls (PlotOPUS)
• Navigation allows selection of state information at a given time point

• [Elements] allows display of results by element instead of nuclide
• [SymNuc] allows specifying nuclides or elements to include in the plot
• [Libtype] allows display of nuclides or elements contained in the light elements, actinides, and fission product isotope sets

• [Nrank] allows limiting the display of the top contributors
• Time, Plot, and Sort Units allows changing the X and Y axis and the nuclides or elements displayed based on contribution
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ORIGEN F71 Plotting | !! Requirement !!
• The F71 plotting requires the ORIGEN decay data which is located in the SCALE 

DATA directory (data/origen_data/origen.rev??.decay.data)
• When plotting an F71 without the decay data a blank plot is presented
• Fix this via the File > Settings > Environment > Decay Data
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ORIGEN F71 | Hands On Initial Plot
• Use File > Open file… and open the 

Advanced_User_Interface/OrigenF71/example.f71

• Observe the 
Navigation State set
are all default 
selected and plot the
multicycle irradiation
and decay times

• Observe the default
plot Data filtering
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ORIGEN F71 | Hands On Units
• Update the Plot and Sort Units to be g/cm3
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ORIGEN F71 | Hands On NRank
• Update the Nrank to 10 to illustrate additional Mass (g/cm3) contributors
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ORIGEN F71 | Hands On Elements and LibType
• Check the Elements checkbox to consolidate isotopes
• Uncheck the 

Fission Products
checkbox 

• Select neptunium 
(np)
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ORIGEN F71 | Hands On Single State Navigation
• Single State selection 

displays a bar plot of Filtered quantity
• Select State 1 T+0
• Note at T=0 it is a uo2 system 

with only U and O
• Use the Arrow keys to 

navigate the State
history from T+0 to T+2.92e+8

• Observe the evolution of the isotope 
inventory over time
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ORIGEN F71 | Hands On Multi State Navigation
• Multi-State selection 

displays time series plot of Filtered quantity
• Select State 1 T+0
• Press the shift key and arrow down

to select multiple State sets
• Observe the data update and assorted 

elements build in over time 
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OPUS PLT
The OPUS provides an ORIGEN postprocessing capability that results in PLT files that can 
illustrate nuclide or element quantities (superseded by ORIGEN F71 capability on prior slides) and 
neutron or photon spectra (Not yet available in the F71 Viewer)
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Sensitivity Data File (SDF)

• Sensitivity of k-eff to cross 
section data

• Sensitivity per unit lethargy

• Sensitivity of k-eff and 
reaction rates to energy-
dependent cross section 
data for each reaction of 
each nuclide in a system 
model
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Result Plots
• Plot of average k-effective by generation run 
• Plot of average k-effective by generations skipped 
• Final edit of fissions, absorptions, and leakage 
• Frequency distributions
• Shannon Entropy  
• Flux plotting
• Etc.
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Result Plots | Hands On K-eff Frequency by Generation
• Use File > Open… and open 

Advanced_User_Interface/PTP/
frequency_by_generations.ptp

• Double left-click the document
plottable item

• Observe the frequency
of k-eff by generation
plotted
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Result Plots | Hands On Average K-eff by Generation 
• Use File > Open… and open 

Advanced_User_Interface/PTP/average_keff_by_generation_run.ptp
• Double left-click the document plottable item
• Observe the frequency of k-eff by generation plotted

• Zoom into last 200
generations and observe the 
Average and Best Estimate
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Plot Review

• You are now practiced in 
– ChartPlot data
– AMPX XS data
– Covariance data
– ORIGEN F71 data and the F71Viewer (PlotOpus) controls
– KENO Result data (PTP) 

• You are aware of 
– Sensitivity Data Files
– OPUS PLT
– ORIGEN Gamma Data

• Questions? 
• Close all open documents via File > Close All
• Close all tabs via right-clicking any tab and selecting Close all tabs for each tab group
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Geometry Visualization 
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Geometry Visualization Overview

• Geometry Viewer Layout
• 2D Viewer Controls
• Perspective Views
• Render Modes
• Mesh Overlay
• 3D Viewer Controls
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Geometry View Overview continued

Perspective 
Views

Available Mesh 
Data to OverlayRender Modes

Camera Zoom 
control

Under-Cursor 
Information

Problem 
Materials

Camera 
Controls

Mesh 
Overlay 

Data

3D Geometry 
Cuts

Display 
crosshair at 
view origin 

Cutplane
control

View origin 
display and 

control

Geometry 
View Controls Perspective ray 

trace render



6262

Geometry Viewer Overview

• Perspective Views provide 2D axis-aligned and 3D geometry renderings

• Available Meshes to Overlay allows combining geometry rendering with mesh-based results

• Render Modes – toggle between different material, outline, and mesh overlay render modes

• Show view origin – highlights exact point at center of the view with a crosshair

• Under-Cursor Information – shows position, and Mixture under cursor 

• View origin – displays and provides control of the origin of the view

• Cutplane controller – interactively manipulates the elevation of the 2D view plane

• Context Menu (via right click) – allows changing color and saving images
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Geometry Visualization Activation
• From within the text editor, click View or click View > View 

geometry
• Alternatively, from 

within the Navigation
panel left click 
document>sequence 
and right click 
geometry and 
select Visualize
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Geometry Visualization | Get Started!

• Using File > Open… open 
Advanced_User_Interface/
Input/example.inp and 
click View
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2D Perspective Views
• 2D Perspective views provide standard orthographic model projections of the top, 

front, and side of the geometry.
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2D Perspective Views : Elevation Control
View plane elevation is controlled via a slide control on the right side of each 
geometry view.
• View plane elevation 

corresponds to view plane 
control – the higher the slider 
control, the higher the view 
plane.
– Top (X-Y) - raising the slider 

increases the Z intersect.
– Front (X-Z) – raising the slider 

increases the Y intersect.
– Side (Y-Z) – raising the slider 

increases the Z intersect.
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Render Modes

Render modes control the information displayed.
• Material displays only the materials/mixtures.

– Can hide geometry region outlines that are the 
same material.

• Material + outline displays the material and the 
region outlines.
– Displays region outline in black.
– Useful for contrasting geometry regions.

• Outline displays only geometry region outlines.
– Displays region outline in material color.

• Overlay displays geometry region outline and 
mesh data results.

• Overlay + boundaries displays geometry region 
outline, mesh boundaries*, and mesh data results
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Geometry Magnification (Zoom) 

Ray traced geometry rendering allows for significant magnification.
• Specify a zoom value.
• Visually specified via a user-drawn 

zoom reticle.
– Left click and drag down and to the right.
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Geometry Visualization | Hands On with 2D Views 

• Click the perspective dropdown 
and select Front (X-Z)

• Observe the new 
rendering of the X-Z
cut at Origin: (0,0,0)
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Geometry Visualization | Hands On with 2D Views 
• Mouse over the model rendering and observe 

information under the cursor displayed in the 
lower-left of the rendering

• Perform a zoom by left-click 
and drag as depicted

• Update the Render mode to Material + Outline
• Observe the new view Origin, 

Zoom factor, and geometry region 
outline
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Geometry View | Origin Display and Control
Often when geometry errors are encountered, an X, Y, Z position is included in the error message. The ability to 
quickly navigate to this location and inspect the geometry is facilitated by the view origin control

• Left-click the View origin display will activate X, Y, Z entry

• 3 Modes of Origin input
– Single value : Updates the view plane elevation (axis intersect – same as slider control but more precise)
– Two values : Updates the view plane 2D origin (pans the image)

• Top (X-Y) – sets the X and Y coordinates of the origin
• Front (X-Z) – sets the X and Z coordinates of the origin
• Side (Y-Z) – sets the Y and Z coordinates of the origin

– Three values :
Updates the view plane elevation and 
the view plane 2D origin

• Double left-click centers
the view origin at the point
clicked
– Useful when combined with

the Show View Origin

• Shift and left-click pans
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Geometry View | Hands On 2D Controls
• Click Show View Origin

• Perform a view pan by clicking the Origin label (lower-right corner) and entering 2 values (-12, 32) and 
pressing the return/enter key

• Perform a X-Z elevation change (change in Y-intersect) by entering a single value (-8)

• Play with the elevation slider 
– Sliding up increases Y-intersect, down decreases Y-intersect

• Perform an elevation and origin change by entering 3 values (35.56, 0, 0)
– Places the view origin at the edge of the outermost 

cylinder for this example problem

• Zoom out by 
– Enter 1.0 in the Zoom Factor field or
– Left-click and dragging up and to the

left and releasing
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Geometry View Origin Preserved Across View Plane
The geometry viewer is often used for geometry verification and debugging. Both 
typically involve known locations – X, Y, Z of lost particle, etc.
• View origin is preserved during view plane changes (Top to Front, etc.)

– Facilitates quickly identifying locations where initial view plane is epsilon (1e-15) off a 
tangent surface

• Cloneable geometry viewer with subsequent view plane change allows quick 
visual comparison of location
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Geometry View | Hands On 2D Clone
• Right-click the example.inp : mavric (Line 5) geometry tab and select Clone tab

• In the new tab change the perspective to Top (X-Y)

• Close the Top (X-Y) tab
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Mesh Overlay Overview

• Loading Mesh Data
• Render Modes
• Contours and color legend
• Scale – Log and Linear
• Range – File, Family, Dataset,

or Custom
• Position, Mesh value, Mesh 

Voxel, Unit, and Mixture under 
Cursor

• Context Menu
• 2D Plot creation
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Mesh Overlay | Loading Mesh Data
With the Available meshes window open, a context menu is available 
via right-click. This context menu will allow loading new, and 
removing or reloading existing mesh files
• Right-click in Available meshes to access the Load mesh file dialog. 

Select the mesh to load 
• Most of SCALE’s major

mesh formats are supported
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Mesh Overlay | Hands On Loading Mesh Data
• Click the Geometry View’s Meshes panel button and observe the Available 

meshes 

• Right-click inside the Available meshes panel and select Load mesh file

• Open the Advanced_User_Interface/Input/example.mt1.3dmap
• Observe the available data sets for plotting
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Mesh Overlay : Hands On Loading Mesh Data Cont’d
• Expand Responses and select 

Response 5
• Change the render mode to 

Overlay
• Click the Controls panel button 
• select the Mesh tab
• Mouse over the data rendering and 

observe the display of the cursor 
position (X-Z), mesh voxel, and mesh 
value



7979

Mesh Overlay |Contours, Color Legend, and Scale
• Controls influenced by MAVRIC’s MeshView plot program
• Allows changing contour count from 25 to 2 enhancing data contrast
• Can improve print quality for printouts
• Linear and logarithmic scale data display
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Mesh Overlay | Data Ranges 
The overlaid dataset’s data range can be selected as the file, family, 
dataset or as custom user-specified.
• The file indicates the entire mesh

file context.
• The family range provides context 

to a selected dataset.
• Custom allows down-selection.
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Mesh Overlay | Integrated 2D Plot Creation 
• Mesh data can be further investigated via the integrated 2D 

plot creation capability 
– 2D Plot creation is available via the Create plot… popup context menu. 

• Plot options include
– Independent axis

• Cartesian X,Y, and Z
• Cylindrical Radial, Theta,

and Z
• Group when group-wise

data is available
– Plot using values or 

indices
– When data is group-wise

axis interval widths can
optionally be divided
linearly or logarithmically 
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Mesh Overlay | Hands On Interactive 2D Plots
• Using the cursor find Voxel 56, 56, 80 
• Right-click and select 

Create Plot …
• Select defaults 

– Plot mesh values along the x axis

• Click OK
• Observe chart file generated and available

in the Navigation panel
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Mesh Overlay | Hands On Interactive 2D Plots
• Double left-click the example*chart > document to plot the data 

• Observe the data and the high and low uncertainties
– Remember the Table view allows copy-and-paste of the data

• Close the Chart tab and file and select the previously opened Geometry tab 
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3D Overview
• Camera 

– Presets
– Panning
– Zooming
– Rotation

• Rendering modes
• Display metadata
• Material controls

– Filter material table

• Geometry Cuts
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Camera presets
• Top: camera is in +Z 

looking into –Z

• Front: camera is in –Y 
looking into +Y

• Right side: camera is
in +X looking into –X

• Isometric: camera is 
above and in front 
+X,-Y,+Z
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Camera presets: 
• Top: camera is in +Z 

looking into –Z

• Front: camera is in –Y 
looking into +Y

• Right side: camera is 
in +X looking into –X

• Isometric: camera is 
above and in front 
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Camera presets: 
• Top: camera is in +Z 

looking into –Z

• Front: camera is in –Y 
looking into +Y

• Right side: camera is 
in +X looking into –X

• Isometric: camera is 
above and in front 
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Camera presets: 
• Top: camera is in +Z 

looking into –Z

• Front: camera is in –Y 
looking into +Y

• Right side: camera is 
in +X looking into –X

• Isometric: camera is 
above and in front 
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Camera presets: 
• Top: camera is in +Z 

looking into –Z

• Front: camera is in –Y 
looking into +Y

• Right side: camera is 
in +X looking into –X

• Isometric: camera is 
above and in front 



90

Camera Panning
• Position fields allow 

absolute camera 
positioning

• Up arrow moves model 
up by moving camera 
down

• Down arrow moves 
model down by moving 
camera up

• Left arrow moves model 
left by moving camera 
right

• Right arrow moves 
model right by moving 
camera left

• Double-click at a point 
pans to re-center at click 
point
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Camera Panning:
• Up arrow moves 

model up by moving 
camera down

• Down arrow moves 
model down by 
moving camera up

• Left arrow moves 
model left by moving 
camera right

• Right arrow moves 
model right by 
moving camera left

• Double-click at a 
point pans to re-
center at click point
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Camera Panning:
• Up arrow moves 

model up by moving 
camera down

• Down arrow moves 
model down by 
moving camera up

• Left arrow moves 
model left by moving 
camera right

• Right arrow moves 
model right by 
moving camera left

• Double-click at a 
point pans to re-
center at click point
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Camera Panning:
• Up arrow moves 

model up by moving 
camera down

• Down arrow moves 
model down by 
moving camera up

• Left arrow moves 
model left by moving 
camera right

• Right arrow moves 
model right by 
moving camera left

• Double-click at a 
point pans to re-
center at click point
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Camera Panning:
• Up arrow moves 

model up by moving 
camera down

• Down arrow moves 
model down by 
moving camera up

• Left arrow moves 
model left by moving 
camera right

• Right arrow moves 
model right by 
moving camera left

• Double-click at a 
point pans to re-
center at click point
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Display metadata
• Mousing-over 

pixels reports the 
material under the 
cursor

• The user can also 
right-click on a 
pixel with material 
information and 
control
– visibility, 
– opacity, 
– and color
– for one or more 

materials under the 
given pixel.
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Materials Controls
• A table containing 

the full listing of 
known materials in 
the model. 

• Table allows 
controlling
– visibility, 
– opacity, 
– and color
– for all material in the 

model.

• Mixture information 
changes as a 
function of selected 
material
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Materials Controls:
Color



98

Materials Controls:
Visibility
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Materials Controls:
Visibility
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Materials Controls:
Opacity
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Material Filter
• Users can type 

material identifiers 
(numbers) to filter 
material table 
rows. 

• Same filtering 
capability 
conducted by 
right-clicking a 
pixel with multiple 
materials and 
selecting 'Manage'
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Zooming
• Rectangle (or lasso) 

zoom is implemented 
just as it is in the 2D 
view
– Click upper-left and 

drag to lower-right

• Quick zoom is 
implemented via a 
Zoom factor text field, 
allowing the user to 
enter a zoom 
(multiplication) factor.
– Show view origin can 

assist in zoom factor 
focus
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Zooming
• Rectangle (or lasso) 

zoom is implemented 
just as it is in the 2D 
view
– Click upper-left and 

drag to lower-right

• Quick zoom is 
implemented via a 
Zoom factor text field, 
allowing the user to 
enter a zoom 
(multiplication) factor.
– Show view origin can 

assist in zoom factor 
focus
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Camera Rotation
• Rotation step size input field 

allows specifying explicit 
rotation.

• Up arrow rotates model up 
by rotating camera down

• Down arrow rotates model 
down by rotating camera 
up

• Left arrow rotates model left 
by rotating camera right

• Right arrow rotates model 
right by rotating camera left

• Arbitrary rotation is 
achieved by Alt+click-and-
drag
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Camera Rotation:
Up

• Rotation step size input field 
allows specifying explicit 
rotation.

• Up arrow rotates model up 
by rotating camera down

• Down arrow rotates model 
down by rotating camera 
up

• Left arrow rotates model left 
by rotating camera right

• Right arrow rotates model 
right by rotating camera left

• Arbitrary rotation is 
achieved by Alt+click-and-
drag



106

Camera Rotation:
Down

• Rotation step size input field 
allows specifying explicit 
rotation.

• Up arrow rotates model up 
by rotating camera down

• Down arrow rotates model 
down by rotating camera 
up

• Left arrow rotates model left 
by rotating camera right

• Right arrow rotates model 
right by rotating camera left

• Arbitrary rotation is 
achieved by Alt+click-and-
drag
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Camera Rotation:
Left

• Rotation step size input field 
allows specifying explicit 
rotation.

• Up arrow rotates model up 
by rotating camera down

• Down arrow rotates model 
down by rotating camera 
up

• Left arrow rotates model left 
by rotating camera right

• Right arrow rotates model 
right by rotating camera left

• Arbitrary rotation is 
achieved by Alt+click-and-
drag
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Camera Rotation:
Right

• Rotation step size input field 
allows specifying explicit 
rotation.

• Up arrow rotates model up 
by rotating camera down

• Down arrow rotates model 
down by rotating camera 
up

• Left arrow rotates model left 
by rotating camera right

• Right arrow rotates model 
right by rotating camera left

• Arbitrary rotation is 
achieved by Alt+click-and-
drag
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Rendering modes
• Material renders only 

material colors, shaded 
according to surface 
normal

• Material+Outline renders 
same as Material with the 
addition of black outlines 
at boundaries

• Outline renders only 
material boundaries using 
Material colors

• Mesh data Overlay and 
Overlay+boundaries
capabilities do data point 
sampling on first 
interacted geometry 
surfaces
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Rendering modes:
Material + outline

• renders same as 
Material with the 
addition of black 
outlines at boundaries
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Rendering modes:
Outline

• renders only material 
boundaries using 
Material colors
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Model Cutting
• Named Block and Pie 

slice model cut styles

• Boundary box cut 
clamping

• Cut offsets allow for 
moving the origin of 
the cut

• Rotation uses Euler-X 
convention to rotate 
cuts to desired angles

• Ability to remove and 
edit/save existing cuts



113

Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)



115

Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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Model Cutting:
Cut Styles 
• Block

– Top half (+Z)
– Bottom half (-Z)
– Left half (-X)
– Right half (+X)
– Front half (-Y)
– Back half (+Y)
– Front-right quarter (-Y,+X)

• Pie slice
– X axis (opening in –Y)
– Y axis (opening in –Z)
– Z axis (opening in -Y)
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3D Model visualization with mesh overlay
• Available when mesh data is loaded and selected, and the 

render mode is Overlay or Overlay + Boundaries
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3D Controls | Hands On
• Change the perspective from Front (X-Z) to 3D
• Depending on your 

CPU clock speed and
core count you may
observe a pause
while the model is 
raytraced

• Note the Origin is now
the Camera not View 
Plane origin

• Observe mouse-over
surface information 
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3D Controls | Hands On Model Cut
• Click the Controls panel button to display sidebar controls

• Click the Cuts tab
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3D Controls | Hands On New Model Cut
• Conduct a default 

Front-right quarter Block
cut by clicking the Add 
button

• Observe the New cut entry 
in the cuts table

• Observe the section 
removed and rendered with 
new overlay data



128

3D Controls | Hands On New Model Cut Cont’d
• Conduct a default 

Top half Block cut by 
selecting the Top half Cut 
style and clicking the Add 
button

• Observe the New cut entry 
in the cuts table

• Observe the section 
removed and rendered with 
new overlay data
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3D Controls | Hands On Updating Existing Model Cut
• Let’s edit the Top-half cut to 

remove less model via a Cut 
offset in Z of 55

• Update Cut offset Z to be 55 
• Click Save
• Observe the cuts table entry 

Description update as well 
as the additional model and 
data visible 
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3D Controls | Hands On Camera Controls
• Select the Camera controls

• Update Rotation step size to 
be 25 

• Rotate down by clicking the 
Orientation down arrow 
button

• Observe the camera Position 
change
– Good to remember the camera 

is moving, not the model
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3D Controls | Hands On Camera Controls
• Update the Zoom to be 5
• Update the Render mode to 

be Overlay + boundaries
– In 3D this mode includes 

rendering boundaries as a 
function of surface normal 
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3D Controls | Hands On Material Controls

• Click the Materials panel 
button to display materials 
controls 

• In the Show column of the 
Material table deselect 
material 1
– Alternatively, right-click the 

region and
select Hide

• Observe Material 1 is hidden 
in the rendering
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3D Controls | Hands On Arbitrary Rotation
• With the Alt (option on Mac) 

key pressed click and drag
up as depicted

• Perform various rotations to 
become familiar with control  
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3D Controls | Hands On Fit to Screen
• Too close or far or simply lost in 

the geometry? 

• A Left mouse button press and 
drag up and to the left and 
release fits the model’s extents to 
the render window

• Zooms out if too
close to model

• Zooms in if too far
away from the 
model 
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3D Controls | Hands On Cut Clamp to Bounding Box
• Select the Cuts tab

• Select the Front-right quarter cut

• The Clamp to bounding box option
updates the ‘infinite’ cutting 
surface into a cutting volume
– E.g., Front-right quarter is defined via

2 planes, clamp to bounding box
updates the cutting surface to be a 
cutting box

• Volume is defined prior to 
application of translation and 
rotation

•
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3D Controls | Hands On Cut Clamp to Bounding Box
• Update Cut Offsets to be 50
• Click Save
• Observe the 

Clamped cut is offset 
+50 from the lower z 
extent of -152.4 
creating a ‘shelf’ at 
z=-102.4
– Mouse over model 

to see X,Y,Z values
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3D Controls | Hands On Cut Clamp to Bounding Box
• Uncheck the Clamp to Bounding 

Box
• Click Save
• Observe the cut offset of 

+50 is ignored as the 
front-right corner cut 
is no longer clamped
to the bounding box
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Geometry Review
• You are now aware and practiced with 2D and 3D Camera 

controls

• You are aware and practiced with 3D Cut and Material 
controls

• You are aware and practiced with 2D and 3D mesh data 
overlay information, controls, and data plotting

• Questions? 
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Advanced User Interface Capabilities Review

• You are now aware and practiced with data plotting
– Various data formats, options, and controls

• You are now aware and practiced with 2D and 3D geometry 
visualization
– Controls, cuts, and data overlay

• Thank you!
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Questions?


