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Scientific Simulation is HOT!

• Flexible, Powerful, Inexpensive (?)
• Remote Collaboration Possible
• Infrastructure Issues:

⇒ Interaction / Control of  Parallel Simulations
⇒ Fault Tolerance ~ Clusters, Networks, etc.
⇒ Adaptable to Changing Resources / Technology

• ORNL Projects:
⇒ HarnessHarness, CUMULVSCUMULVS, CCACCA
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Distributed Computing History at ORNL
PVM was developed as a tool to help us explore HDC issues.
Software has been redesigned from scratch every 2-3 yrs
to study emerging architecture, network, and user needs.

1990 Heterogeneity - architecture, data, power, network...
explore the problems and research issues in heterogeneous computing

1991 Robust, Portable Programming Environment
study how to create a robust, portable programming environment for HDC

1993 Transparent Multiprocessor integration
efficient multi-protocol handling of distributed and shared memory computers

1995 Fault Tolerance and Extensibility
study VM and application fault tolerance. Design first VM plug-in interfaces

1998 Windows and Unix interoperability
enable the millions of NT and Win2000 hosts to exploit cluster computing

Next Step is Harness
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HARNESS HARNESS 
Exploring New Capabilities in Heterogeneous Distributed ComputinExploring New Capabilities in Heterogeneous Distributed Computingg

Building on our experience and success with PVM we will
create a fundamentally new heterogeneous virtual machine
environment based on three key research concepts:

• Parallel Plug-in Environment
Extend the concept of a plug-in to the parallel computing world.
Dynamic with no restrictions on functions.

• Distributed Peer-to-Peer Control
No single point of failure unlike typical client/server models.

• Multiple Distributed Virtual Machines Merge/Split
Provide a means for short-term sharing of resources and 
collaboration between teams.

www.csm.ornl.gov/harness
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HARNESS MotivationHARNESS Motivation
Needs of Simulation Science and Cluster ComputingNeeds of Simulation Science and Cluster Computing

• develop applications by plugging together 
component models.

• customize/tune virtual environment for application’s 
needs and for performance on existing resources.

• support long-running simulations despite maintenance, 
faults, and migration (dynamically evolving VM).

• adapt virtual machine to faults and dynamic 
scheduling in large clusters (C-Plant).

• Provide framework for collaborative simulations (in spirit 
of CUMULVS or a collaborative PSE). 
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HARNESS TeamHARNESS Team
Collaborative Effort by the Developers of PVMCollaborative Effort by the Developers of PVM

Al Geist, 
Jim Kohl, Stephen Scott, Conrad Albrecht-Buehler, Wael Elwasif 

Oak Ridge National Laboratory

Jack Dongarra, 
Graham Fagg, Martin Swany, Nathan Garner

University of Tennessee

Vaidy Sunderam, 
Paul Gray, Mauro Migliardi, Gopi Sankar

Emory University

www.csm.ornl.gov/harness
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HARNESS Virtual MachineHARNESS Virtual Machine
Scalable Distributed Control and CCAScalable Distributed Control and CCA--Based Daemon Based Daemon 

Host D

Host C

Host B

Host A

process control

user features

HARNESS daemon

Component
based daemon

Merge/split with other VMs

Virtual
Machine

Another
VM

Customization
and extension
by dynamically
adding plug-ins

Operation within VM uses
Distributed Control
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HARNESS ArchitectureHARNESS Architecture
Hlib and Harness daemon within hostHlib and Harness daemon within host

Example: PVM Application on Harness

Application
task

Hlib PVM plug-in

PVMD plug-in

Host A

Application
task

Hlib

Harness
daemon

PVM plug-in

PVMD plug-in

Host B
Communication
direct task-task

Language
independent
interface

Task to 
pvmd API

Distributed control

TCP/IP

TCP/IP

Harness
daemon
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HARNESS Development PlanHARNESS Development Plan
Plan is to produce the core framework and a couple key 
plug-ins that will provide a practical environment and
illustrate the capabilities of HARNESS:

• Harness Core  
Task library and Harness Daemon software
Provides API to load, unload plug-ins and distributed control.

• PVM Plug-in  
Provides PVM API veneer to support exiting PVM applications.

• Fault tolerant MPI plug-in   
Provides MPI API for 30 most used functions. Semantics 
adjusted to allow recovery from corrupted communicator.

• VIA/FM communication plug-in
To illustrate how different low level communication plug-ins
can be used within Harness, and to provide high performance.
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Harness Core ImplementationsHarness Core Implementations
Two Different Schemes are Being Explored Two Different Schemes are Being Explored 

• C Scheme (ORNL)
⇒ Based on dynamically linked / shared libraries
⇒ Advantage ~ DLL / lib can be written in the language of the app
⇒ Potential for higher performance plug-ins (compiled binary)

• Java (2) Scheme (Emory)
⇒ Based on JVM dynamic class loader
⇒ Advantage ~ fast prototyping 
⇒ Leverages wealth of existing Java specs, JINI, JavaBeans, RMI, 

Java Spaces, etc.
⇒ Good integration with emerging Java SC apps and interfaces
⇒ Beta Release! 
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Symmetric PeerSymmetric Peer--toto--Peer Distributed ControlPeer Distributed Control
RequirementsRequirements

• No single point of failure for Harness.
⇒ It survives as long as one member still lives.

• All members know the state of the virtual machine
⇒ Knowledge is kept consistent w.r.t. the order of changes of state

(Important parallel programming requirement!)

• No member  is more important than any other
⇒ At any instant
⇒ There’s no “control token” being passed around



ORNL Kohl/2000-12

Distributed ControlDistributed Control
Harness Overlapping Two Phase ArbitrationHarness Overlapping Two Phase Arbitration

Harness kernels on each host
have arbitrary priority assigned to them
(new kernels are always given the lowest priority)

A  task on this host
requests a new host be added 

VM state 
held by 

each kernel

1.

Virtual machine
3. Each adds request to a

list of pending changes

2. Send host/T#/data
to neighbor in ring
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Harness Distributed ControlHarness Distributed Control
Control is Asynchronous and ParallelControl is Asynchronous and Parallel

Supports
multiple

simultaneous 
updates

add
host

Supports
fast host
adding

Parallel recovery
from multiple
host failuresFast 

host delete
or recovery
from fault
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HARNESS ScalabilityHARNESS Scalability
Variable Distributed Control Loop Size Variable Distributed Control Loop Size 

Virtual machine
Size of the Control Loop
1 <= S <= (size of VM)

For small VM and ultimate
fault tolerance S = (size of VM)

For large VM a random selection
of a few  hosts (f.e. S = 10) gives
a balance of multi-point  failure
and performance.

For  S = 1, distributed control
becomes simple client/server
model.



ORNL Kohl/2000-15

Fault Tolerant MPIFault Tolerant MPI
Motivation   Motivation   

Two major drawbacks to MPI are:
• lack of interoperability - being addressed by IMPI and MPI-Connect
• lack of fault tolerance - any failure is catastrophic

As application and machine sizes grow the
MTBF is less than the application run time. 

MPI standard is based on a static model any decrease in tasks
leads to corrupted communicator (MPI_COMM_WORLD).

Develop MPI plugin that takes advantage of Harness 
robustness to allow a range of recovery alternatives 
to an MPI application. Not just another MPI implementation.

FT-MPI follows the syntax of MPI standard

Being used
on Blue at LLNL
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HARNESS Research StatusHARNESS Research Status
Java-based HARNESS prototype created at Emory 

• used to test parallel plug-in concepts
• integration with JINI underway

IceT package developed by Paul Gray (Iowa St.)
• demonstrates merging and splitting of virtual machines
• dynamically switching communication (MPI to CCTL)

C-based HARNESS kernel and distributed control
• feasibility demonstrated at ORNL
• production release in progress

C-based FT-MPI plug-in prototype developed at UTK 
• built on top of PVM 3.4 API
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Harness Enables New Kinds of ApplicationsHarness Enables New Kinds of Applications
Thinking “Outside the Box” Thinking “Outside the Box” ---- It’s not just for Scientific Computing It’s not just for Scientific Computing 

Harness is still just a research project but its potential is great

Applications follow user
roaming wearable computers

On-the-fly simulation tuning
plug-in different methods
if simulation evolves to need them

Teams of  tasks patrol and monitor 
local network for performance 
or security
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(Collaborative,  User Migration,  User Library  for  Visualization  and  Steering)

• Collaborative Infrastructure for Interacting with 
Scientific Simulations:
⇒ Run-Time Visualization by Multiple Viewers

→ Dynamic Attachment

⇒ Coordinated Computational Steering
→ Model  &  Algorithm

⇒ Heterogeneous Fault Tolerance
→ Automatic Fault Recovery and Task Migration

⇒ Coupled Models…
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CUMULVS
coordinates the consistent collection and dissemination

of information to/from parallel tasks to multiple viewers

viewer
viewer

viewer

task

task

tasktasktasktask

task

tasktasktask

Unix Host A

remote person
using AVS

local  person
using custom
GUI

CUMULVS
exists in three pieces:
task part, viewer part,

and separate fault 
recovery daemon

remote person
using virtual reality
interface

NT Host B
Unix Host C

distributed parallel application or simulation
supports most target platforms (PVM/MPI, Unix/NT, etc.)
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Collaborative Combustion Simulation



ORNL Kohl/2000-21

Multiple Simultaneous Views

Density Temperature
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Multiple Distinct Views
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CUMULVS Particle Handling

• Particle Data Fundamentally Different
⇒ Nested Data Fields, Explicit Coordinates

• Particle-Based Decomposition API
⇒ User-Defined, Vectored Accessor Routines

• Viewing Particle Data
⇒ AVS Module Extensions
⇒ Tcl/Tk Slicer Particle Mode
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Coordinated Steering
• Multiple, Remote Collaborators
• Simultaneously Steer Different Parameters

⇒ Physical Parameters of Simulation
⇒ Algorithmic Parameters ~ e.g. Convergence Rate

• “What If ?” Analyses
⇒ Explore Non-Physical Effects

• Efficient Experimentation Cycle
⇒ Keep Simulation On Track
⇒ Crop Off  Experiments Gone Awry…



ORNL Kohl/2000-25

Heterogeneous Checkpointing

• Application Defines Its Own State
⇒ Provide CUMULVS with Semantic Information
⇒ CUMULVS Handles Checkpoint Collection
⇒ Automatic Fault Recovery System

• Efficient & Flexible Checkpoints
⇒ Not Full Core Image
⇒ Semantics → Heterogeneous Restart & Migration
⇒ On-The-Fly Reconfiguration Also Possible…
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Run-Time System Architecture

• One Checkpointing 
Daemon (CPD) Per Host
⇒ Ckpt Collector / Provider
⇒ Run-Time Monitor
⇒ Console for Restart / Migrate

• CPDs Comprise Fault-
Tolerant Application…
⇒ Handle Failure of Host / CPD
⇒ Coordinate Redundancy
⇒ Ring Topology
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Manual Software Instrumentation

• SPDT 98 Case Study ~ SW Instrumentation Cost

Instrumentation: Seismic: Wing Flow:
Original Lines of Code 20,632 2,250

Vis / Steer Variable Decls
CP Restart Initialization
CP Rollback Handling
Total Instrumentation

3 3
73

21 12
48

41 34

Vis / Steer System Init

204 ~ 1.0 % 188 ~ 7.7 %
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Checkpointing Efficiency
• SPDT 98 Case Study ~ Execution Overhead

Seconds per Iteration
Experiment: SGI: Cluster: Hetero:
Seismic - No Checkpointing
Seismic - Checkpoint for Restart
Seismic - Checkpoint for Rollback

2.83 6.23 9.46
2.99 6.50 10.76
3.03 6.66 10.90

Wing - No Checkpointing
Wing - Checkpoint for Restart
Wing - Checkpoint for Rollback

0.69
0.77
0.79

1.58
1.71
1.71

6.14
7.10
7.30

(Checkpointing Every 20 Iters.)

Seismic Overhead:  4-14% Restart, +1-3% Rollback.
Wing Overhead:  8-15% Restart, +0-2.5% Rollback.
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Seismic Example ~ 3D (AVS)
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Air Flow Over Wing Example ~ 3D (AVS)
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Coupling Data Fields in Simulation Models
Using CUMULVS

• Natural Extension to Viewer Scenario
⇒ Promote “Many-to-1” → “Many-to-Many”

• Translate Disparate Data Decompositions
⇒ Complements PAWS Coupling Work
⇒ Builds on CCA (Common Component Architecture) Forum

V

E.g. Regional Climate Assessment

Ocean Atmosphere
Temperature

CUMULVS
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Future CUMULVS Plans

• Application Interface:
⇒ Assist Manual Instrumentation of Applications

→ GUI, Pre-Compiler...

• Checkpointing Efficiency:
⇒ Tasks Write Data in Parallel / Parallel File System
⇒ Variable Redundancy Levels, Improve Scalability

• Portability:
⇒ Other Messaging Substrates

→ Reduced Functionality for MPI / MPI-2…

http://www.csm.ornl.gov/cs/cumulvs.html



ORNL Kohl/2000-33

Common Component Architecture (CCA)
• Component Architecture for Scientific Simulation

⇒ Special Emphasis on High-Performance / Parallelism

• Reusable “Components” Connect Via “Ports”
⇒ Forum Creating Specification and Reference Framework

Collective / MxN
(Parallel Data Exchange)Direct Connect Ports

(Local Components Share Memory)
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Common Component Architecture (CCA) / ACTS Toolkit
Oak Ridge National Laboratory

Fault 
Tolerance

GIST
(LoCascio)

Comp.
Chemistry
(Bernholdt)

CUMULVS
(Kohl)

Mesh & Field
(SNL/ANL)

MxN
Framework
(LLNL/Utah)

MxN
(Kohl)

Computational 
Steering

Components

Framework

CCA

Visualization
(Wilde)

ESI
(SNL)

CCA Demo
SC99MxN

(LANL)

Global Arrays
(PNNL)
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MxN Parallel
Data Mapping
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Collective MxN Example
Atmosphere

Collective Port

Ocean
getDataField( space, time )getDataField( space, time )
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High-Performance Parallel Collective Port
AtmosphereOcean

getDataField( space, time )getDataField( space, time )

getDataField( space, time )getDataField( space, time )

getDataField( space, time )getDataField( space, time )

getDataField(  space, time )getDataField(  space, time )
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Summary of  ORNL Scientific Simulation
• Harness ~ Next Generation HDC Environment

⇒ Pluggable Virtual Machine, Distributed Control

• CUMULVS ~ Interacting with Simulations On-The-Fly
⇒ Visualization, Steering, Fault Tolerance

• Common Component Architecture (CCA)
⇒ Harness Pluggability Builds on CCA Foundation
⇒ CUMULVS Technology Used for MxN / Coupling

CCA

Harness

CUMULVS
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